CUBE 6.4.1 compatibility with Windows 10

my system keeps asking for a restart since I have installed CUBE 6.4.1.

Could someone from community help in resolving the issue.

Could you try installing the latest version 6.4.3? If you are under active maintenance then you can ask support@citilabs.com