Cube 6.4.1 Unable to open the text editor

My Cube 6.4.1 cannot open any scripts file or print file.
It pops out the error message " unable to open the text editor" or just automatically close the program…
Anyone knows how to resolve?
It was working yesterday, just all of a sudden something went wrong today…

Other higher version (6.4.2 & 6.4.4 work fine to open the text files…)

We have been having the same issue all day long at my company. The license server has been restarted but didn’t solve the problem.

Dear All,

This may be related to your Cube and corresponding GIS version on the machine. Cube 6.4.1 supports ArcGIS version upto 10.3.X only and if your machine has ArcGIS 10.4.x or above with 6.4.1, then Text Editor may not work.

Can you confirm what Cube version your machines have? Also, please send an email at with a short message about your issue and we will reply with plausible solutions.

Thank you.

I have ArcGIS 10.2. It was working fine the previous day, it gave the error the following day.

The Cube on my computer is v6.4.1, and I have the ArcGIS 10.2.
The text editor was working fine the day before… no update to the ArcGIS or the Windows system during these days…
I’ll double check our company’s computer again on Monday and send you an email about the issue.

Ok, In that case, a simple re-installation of Cube 6.4.1 should work.

Could you please try?

Thank you.

Same issue for me. Working totally fine a few days ago and now same error message/problem.
Running Cube 6.4.1 and ArcGIS 10 SP1

We’ve tried to re-install the Cube 6.4.1 several times. But it didn’t work.
I’ve checked the software versions again this morning. The Cube version is v6.4.1 and the GIS version is 10.2.2.

Not sure what caused this issue…

I’ve sent the email to the Citilab support. I was told that this issue was solved in later versions of Cube.
However, it is common that in some states the government requests to use a lower version (For example, Florida’s official approved Cube version is 6.4.1).

Is that possible to resolve this issue in Cube 6.4.1?

Hi all, just a quick update… The latest response from Citilab support: they are working on the license signature certificate authorization to fix this issue…
Guess we should use the later version for now…

The same problem is still here. No problem days ago, not working now on the same machine and software. It doesn’t make sense. Please do something about this.
Ver 6.4.1(Oct 01 2015)
GIS version 10.3.4959